Задать вопрос

Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с нулем, а между собой можно сравнивать только абсолютные величины чисел x и y.

+1
Ответы (1)
  1. 2 декабря, 06:00
    0
    program zz1;

    var x, y:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число x '); / / вводим с клавиатуры первое число

    read (x);

    write (' введите второе число y '); / / вводим с клавиатуры второе число

    read (y);

    if x = y then write (' знака у разности х - у не будет ')

    else

    if (x > y) / / проверяем условие, если первое число больше другого, то

    then write (' знак разности х - у будет положительным ') / / выводим один ответ

    else write (' знак разности х - у будет отрицательным '); / / выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны целые числа x и y. Написать программу определения знака разности x-y. Разность вычислять нельзя. Разрешается сравнивать числа x и y с ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
Язык Паскаля составить программу, которая будет вычислять сумму, разность, произведение и частное от деления первого числа на второе
Ответы (1)
Напишите программу, которая по введённым с клавиатуры числам e, f и g будет вычислять значение коэффициентов a, b и c квдратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать
Ответы (1)