Задать вопрос

В массиве хранится информация о годе рождения каждого из 30 человек. Определить порядковый номер самого старшего по возрасту человека?

+4
Ответы (1)
  1. 8 сентября, 13:27
    0
    Var

    a:array[1 ... 30] of integer; / /переменные для массива;

    i, k, min:integer; / /переменные целого типа;

    begin

    writeln ('Введите годы рождения '); / /просим ввести данные;

    for i:=1 to 30 do / /используем цикл присваем значение;

    begin

    readln (a[i]); / /вывод значения а;

    end;

    min:=a[1]; / /присваиваем значение переменной;

    for i:=1 to 30 do / /цикл;

    begin

    if a[i]
    begin

    min:=a[i];

    k:=i;

    end;

    end;

    writeln ('Порядковый номер самого старшего по возрасту человека равняется ', k); / /вывод.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве хранится информация о годе рождения каждого из 30 человек. Определить порядковый номер самого старшего по возрасту человека? ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Информация о количестве жильцов в каждой из четырех квартир каждого этажа 12-этажного дома хранится в двумерном массиве (в первой строке - информация о квартирах первого этажа, во второй - второго и т. д.). В каждой квартире проживает одна семья.
Ответы (1)
Каждому устройству поставьте в соответствие вид информации, с которым оно работает. Клавиатура Числовая информация Монитор Текстовая информация Принтер Графическая информация Микрофон Звуковая информация Акустические колонки Видеоинформация Сканер
Ответы (1)
Работа со словарём. Продолжи предложение: Новое слово (словосочетание) / Значение слова (словосочетания) Зрительная информация / Воспринимается органами зрения Слуховая информация / Воспринимается ... Вкусовая информация / Воспринимается ...
Ответы (1)
В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого и самого дорогого товара и его индекс.
Ответы (1)
В массиве хранится информация о среднедневной температуре за каждый день июля. Определить количество двух самых тёплых дней в этом месяце.
Ответы (1)