Задать вопрос

В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого и самого дорогого товара и его индекс.

+5
Ответы (1)
  1. 15 марта, 03:45
    0
    program zz1;

    var mas:array[1 ... 10] of integer;

    i, min, max, k1, k2:integer;

    begin

    for i:=1 to 10 do / /заполняем массив случайными числами от 10 до 30

    mas[i]:=random (21) + 10;

    for i:=1 to 10 do / /выводим полученный массив на экран

    write (mas[i],' ');

    writeln; / /переходим на новую строку для вывода

    max:=0; min:=1000; / /задаем начальные значения

    for i:=1 to 10 do

    if mas[i]>max then begin max:=mas[i]; k1:=i; end; / /проверяем, если число из массива больше максимального, то записываем его в максимальное

    for i:=1 to 10 do

    if mas[i]
    writeln ('самый дешевый товар стоит - ', min, ' его номер - ', k2); / /выводим ответ

    write ('самый дорогой товар стоит - ', max, ' его номер - ', k1);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого дешевого и самого дорогого ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Найти минимальный чётный элемент в массиве и его индекс. 2) Заполнить одномерный массив степенями числа 2. Всего 10 элементов в массиве.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Задачи по теме массив 1. В массиве хранятся сведения об оценках 25 учеников по химии. Определить количество неуспевающих по химии учеников. 2. В мвссиве хранятся сведения об общей стоимости товаров, проданных фирмой за каждый день марта.
Ответы (1)
Каждому устройству поставьте в соответствие вид информации, с которым оно работает. Клавиатура Числовая информация Монитор Текстовая информация Принтер Графическая информация Микрофон Звуковая информация Акустические колонки Видеоинформация Сканер
Ответы (1)
Работа со словарём. Продолжи предложение: Новое слово (словосочетание) / Значение слова (словосочетания) Зрительная информация / Воспринимается органами зрения Слуховая информация / Воспринимается ... Вкусовая информация / Воспринимается ...
Ответы (1)