Задать вопрос

напишите программу. Даны три действительных числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - отрицательные.

+3
Ответы (1)
  1. 27 апреля, 10:08
    0
    program zz1;

    var a, b, c:real; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if a > 0 then a:=sqr (a) else a:=sqr (sqr (a));

    if b > 0 then b:=sqr (b) else b:=sqr (sqr (b));

    if c > 0 then c:=sqr (c) else c:=sqr (sqr (c));

    writeln (' полученные числа а = ', a, ' b = ', b, ' c = ', c); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «напишите программу. Даны три действительных числа. Возвести в квадрат те из них, значения которых неотрицательны, и в четвертую степень - ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы