Задать вопрос

Найти сумму от 100 до 200, кратных 17

+3
Ответы (1)
  1. 6 апреля, 17:24
    0
    program zz1;

    var i, s:integer; / / задаем переменные целого типа

    begin

    for i:=100 to 200 do / / организуем цикл, в котором переберем числа от ста до двухсот

    begin

    if i mod 17 = 0 then s:=s + i; / / проверяем, если очередное число делится на семнадцать без остатка, то добавляем число в сумму

    end;

    write (' сумма чисел от 100 до 200, кратных 17 = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму от 100 до 200, кратных 17 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. найти сумму первых 10 чисел, кратных 7; 2. вывести на экран 11 первых чисел кратных 5; 3. составить программу рисования 18 прямоугольников синего цвета, координаты которых определяется случайным образом, а стороны равны а=140, b=40.
Ответы (1)
Найти произведение и сумму чисел больших 100 и меньших 200 и кратных 5 на языке программирования Pascal. Следующими способами: While, For, Repeat.
Ответы (1)
Написать программу в паскале: Найти сумму чисел от 100 до 200 кратных 17.
Ответы (1)