Задать вопрос

Найти произведение и сумму чисел больших 100 и меньших 200 и кратных 5 на языке программирования Pascal. Следующими способами: While, For, Repeat.

+5
Ответы (1)
  1. 23 июня, 03:30
    0
    program zz1;

    var i, s, p:integer; / / задаем переменные целого типа

    begin

    p:=1; s:=0;

    for i:=100 to 200 do / / организуем цикл, в котором переберем все числа от единицы до тысячи

    begin

    if (i mod 5 = 0) / / проверяем условие, если число кратное пяти, то

    then begin s:=s + i; p:=p * i; end; / / получаем сумму и произведение

    end;

    writeln (' произведение чисел = ', p); / / выводим ответ

    writeln (' сумма чисел = ', s);

    p:=1; s:=0;

    i:=100;

    while i<=200 do

    begin

    if (i mod 5 = 0) / / проверяем условие, если число кратное пяти, то

    then begin s:=s + i; p:=p * i; end; / / получаем сумму и произведение

    i:=i+1;

    end;

    writeln (' произведение чисел = ', p); / / выводим ответ

    writeln (' сумма чисел = ', s);

    p:=1; s:=0;

    i:=100;

    repeat

    if (i mod 5 = 0) / / проверяем условие, если число кратное пяти, то

    then begin s:=s + i; p:=p * i; end; / / получаем сумму и произведение

    i:=i+1;

    until i>200;

    writeln (' произведение чисел = ', p); / / выводим ответ

    writeln (' сумма чисел = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти произведение и сумму чисел больших 100 и меньших 200 и кратных 5 на языке программирования Pascal. Следующими способами: While, For, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дана непустая последовательность чисел оканчивающаяся нулем. Найти: а) сумму всех чисел последовательности, б) кол-во всех чисел последовательности. решить через Pascal ABC через repeat, for или while
Ответы (1)
написать программа выводу на экран всех 3 значных чисел, кратных 6 и 4, и заканчивающихся на цифру 8. Программу писать тремя способами с использованием циклов for, while, repeat
Ответы (1)
1) Найдите сумму и произведение целых чисел больших 13 и меньших 100 и кратных 4.
Ответы (1)
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)