Задать вопрос

Вводится строка текста из N символов, слова разделены одним пробелом. Найти длину самого длинного слова. Написать программу в Паскале.

+3
Ответы (1)
  1. 12 августа, 04:09
    0
    var i, k, l:integer; s:string; begin readln (s); k:=0; i:=1; while ibegin l:=0; while (s[i]' ') and (i begin l:=l+1; i:=i+1; end; i:=i+1; if l>k then k:=l; end; writeln (k); end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вводится строка текста из N символов, слова разделены одним пробелом. Найти длину самого длинного слова. Написать программу в Паскале. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать в Паскаль программу для решения следующей задачи. Вводится строка. Написать пользовательскую функцию, которая возвращает строку 'DA', если количество символов в ней двухзначное число и возвращает 'NET', если количество символов однозначное
Ответы (1)
1. Два текста содержат одинаковое количество символов. Первый текст составлен с помощью алфавита, в котором 16 символов. Второй текст составлен с помощью алфавита, в котором 256 символов.
Ответы (1)
С клавиатуры вводится строка. Проверьте, может ли эта строка быть записью числа в десятичной системе счисления. Учтите, что число может быть не обязательно целым.
Ответы (1)
Написать в Паскаль программу для решения следующей задачи. Вводится строка, состоящая только из цифр без нуля. Написать пользовательскую функцию, которая возвращает строку, добавляя после каждого символа символ '0'.
Ответы (1)
Два текста содержат одинаковое кол-во символов. Первый текст составлен из символов алфавита мощностью 256 символов, второй-мощностью 16 символов. Во сколько раз различаются информационые объемы этих текстов?
Ответы (1)