Задать вопрос
13 января, 00:26

Найти количество целых трехзначных чисел, произведение цифр которых равно N (вводится с клавиатуры). создать программу на Паскале

+1
Ответы (1)
  1. 13 января, 03:28
    0
    var

    N, k, i, pr: integer;

    begin

    / / Организовываем ввод

    write ('Введите N ');

    readln (N);

    pr : = 0;

    k : = 0;

    / / Запускаем цикл с перебором всех трехзначных чисел от 100 до 999

    / / В теле цикла проверяем если произведение их цифр равно N

    //то увеличиваем количество k на 1

    for i: = 100 to 999 do

    begin

    pr: = (i mod 10) * ((i div 10) mod 10) * (i div 100);

    if pr = N then k : = k + 1;

    end;

    writeln ('Количество трехзначных чисел с суммой цифр равной ', N,' составляет ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти количество целых трехзначных чисел, произведение цифр которых равно N (вводится с клавиатуры). создать программу на Паскале ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму. число N вводится с клавиатуры.
Ответы (1)
На паскале нужно сделать. с клавиатуры вводится n элементов массива целых чисел вывести количество чисел которые попадаются в диапозоне от 10 до 30
Ответы (1)
Создать программу которая вычисляет сумму чисел а и б, значения которых вводится с клавиатуры
Ответы (1)