Задать вопрос

Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму. число N вводится с клавиатуры.

+1
Ответы (1)
  1. 10 мая, 22:32
    0
    program zz1;

    var n, i:integer; / / задаем переменные целого типа

    d1, a:real; / / задаем переменную не целого типа

    begin

    write (' введите заданное число n '); / / вводим с клавиатуры число

    read (n);

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    write (' введите произвольное число '); / / вводим с клавиатуры число

    read (a);

    d1:=d1 + a; / / прибавляем введенное число к сумме

    end;

    writeln (' найденная сумма чисел = ', d1:5:2); / / выводим ответ в формате пять знаков для всего числа и два знака после точки

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать на Паскале программу, которая запрашивает с клавиатуры N произвольных чисел и ищет их сумму. число N вводится с клавиатуры. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
Напишите программу в Паскале, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа сообщает, сколько чисел было введено.
Ответы (1)