Задать вопрос

С клавиатуры вводится 10 целых чисел. подсчитать, сколько положительных чисел были введены и их суммы.

+2
Ответы (1)
  1. 14 апреля, 03:28
    0
    program zz1;

    var a, b, r, i:integer; / / задаем переменные целого типа

    begin

    for i:=1 to 10 do / / организуем цикл на десять повторений

    begin

    read (a); / / вводим очередное число с клавиатуры

    if a > 0 / / проверяем условие, если введенное число больше нуля, то

    then begin r:=r + a; b:=b + 1; end; / / добавляем число в сумму и считаем его

    end;

    writeln (' сумма положительных чисел среди введенных = ', r); / / выводим ответы

    writeln (' количество положительных чисел среди введенных = ', b);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводится 10 целых чисел. подсчитать, сколько положительных чисел были введены и их суммы. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
С клавиатуры вводится произвольная последовательность положительных чисел, за которой следует 0. Определить: 1) Количество четных чисел. 2) Сумму чисел, заканчивающихся на 5 и положительных Найти сумму чисел: 5+10+15+20+ ...+n
Ответы (1)
Задача в паскале среди 10 введенных с клавиатуры чисел подсчитать количество отрицательных и произведение положительных чисел рассмотреть случай когда положительных чисел нет
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)