Задать вопрос
5 августа, 10:37

Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. (на паскале)

+3
Ответы (1)
  1. 5 августа, 11:29
    0
    procedure vvod;

    begin

    randomize;

    writeln ('введи кол-во элементов в массиве');

    read (n);

    for i:=1 to n do

    massiv[i]:=random (61) - 30;

    end;

    procedure vivod;

    begin

    for i:=1 to n do

    begin

    write (massiv[i]:4);

    writeln;

    end;

    end;

    procedure umn;

    begin

    for i:=1to n do

    if massiv[i]>0

    then massiv[i]:=massiv[i]*2

    else massiv[i]:=massiv[i]*10;

    end;

    procedure sred_arifmet;

    var

    kol:integer;

    begin

    kol:=0;

    s:=0;

    for i:=1 to n do

    if massiv[i]>0

    then

    begin

    kol:=kol+1;

    s:=massiv[i]+s;

    end;

    h: = (s/kol);

    writeln ('среднее арифметическое = ');

    writeln (h:4:1);

    end;

    begin

    clrscr;

    vvod;

    vivod;

    umn;

    vivod;

    sred_arifmet;

    vivod;

    end.

    Второй вариант:

    Program CyberForum;

    var

    a:array[1 ... 101] of real;

    max, min:real;

    i:integer;

    begin

    max:=0;

    min:=0;

    Write ('Массив: ');

    for i:=1 to 100 do

    begin

    a[i]: = (random (4000) - 2000) / 100;

    write (a[i]:9:2);

    if a[i]>0 then

    max:=max+1;

    if a[i]<0 then

    min:=min+1;

    end;

    Writeln;

    Writeln ('Кол-во положительных: ', max);

    Writeln ('Кол-во отрицательных: ', min);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Оставить программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)