Задать вопрос

Составить программу для вычисления значения выражения max (x+y xy) + 2 паскаль

+2
Ответы (1)
  1. 8 февраля, 05:07
    0
    program zz1;

    var x, y, max:integer; / / задаем переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (x);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (y);

    if x + y > x * y / / проверяем условие, если сумма введенных чисел больше их произведения, то

    then max:=x + y / / записываем в максимальное сумму

    else max:=x * y; / / записываем в максимальное произведение

    write (' полученное значение выражения = ', max + 2); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу для вычисления значения выражения max (x+y xy) + 2 паскаль ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы