Задать вопрос

Написать программу в Pascal числа a, b и c вводятся с клавиатуры. найти max (a, a+b) + max (a, b+c) / 1+max (a+b*c, 1,5)

+5
Ответы (1)
  1. 2 июня, 10:34
    0
    program zz1;

    var a, b, c:integer; / /задаем переменные целого типа

    d:real;

    function max (x, y:integer) : integer;

    var p:integer;

    begin

    if x > y then p:=x else p:=y;

    max:=p;

    end;

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    d:=max (a, a + b) + max (a, b + c) / 1 + max (a + b*c, 1.5);

    write (' полученный результат = ', d);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в Pascal числа a, b и c вводятся с клавиатуры. найти max (a, a+b) + max (a, b+c) / 1+max (a+b*c, 1,5) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Var a:array[1 ... 10] of integer; i, m, max:integer; begin randomize; m:=0; for i:=1 to 10 do begin a[i] random (50); writeln ('a[', i,']=', a[i]); end; max:=a[1]; for i:=2 to 10 do if a[i]>max then max:=a[i];
Ответы (1)
Написать программу: c клавиатуры последовательно вводятся числа, пока не введут 0. Вывести на экран количество положительных и отрицательных чисел, введенных с клавиатуры.
Ответы (1)
Вывести числа, кратные 3 в интервале от а до b (вводятся с клавиатуры). Напишите программу в Pascal
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)