Задать вопрос

Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество элементов кратных 3.

+3
Ответы (1)
  1. 12 января, 10:09
    0
    program massiv;

    var a: array[1 ... 15] of integer;

    i, kol: integer;

    begin

    writeln ('Включаем генератор случайных чисел');

    randomize;

    writeln ('Заполняем массив');

    for i:=1 to 15 do a[i]:=random (-15);

    writeln ('Подсчитываем');

    for i: = 1 to 15 do if a[i] mod 3 = 0 then kol : = kol + 1;

    writeln ('Количество чисел, кратных 3 равно', kol);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу, которая заполняет массив s [1 ... 15] случайными целыми числами в диапазоне от - 15 до 5 и находит количество ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)
1. Составить программу ввода элементов массива A[1 ... 12]случайными целыми числами в диапазоне от - 10 до 10 и находит количество элементов с отрицательными значениями. 2. Составить программу ввода элементов массива A[1 ...
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до10 и находит количество элементов, которые больше своего соседа слева.
Ответы (1)
Составьте программу. которая заполняет массив b [1 ... 8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элемеyтов с нечётными значениями
Ответы (1)
Составьте программу, которая заполняет массив а[1 ... 10] случайными целыми числами в диапазоне от 1 до 20 и вычисляет произведение элементов массива с чётными значениями и среднее арифм. элементов массива с нечётными значениями
Ответы (1)