Задать вопрос

Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов следующего дня. К сожалению, проспать 14 часов ему не удалось, т. к. будильник зазвонил уже через 2 часа. Исследователь забыл, что на будильнике, имеющем 12-ти часовой циферблат, можно задать время до звонка только менее 12 часов. Требуется написать программу, которая определяет, сколько часов успеет проспать исследователь, прежде чем будильник его разбудит. Входные данные: Два целых числа S и T (1 < S < 24, T < 12) - час, когда исследователь лег спать, и час, на который он установил будильник. Выходные данные: Целое число - через сколько часов зазвонит будильник.

+1
Ответы (1)
  1. 5 сентября, 17:22
    0
    program zz1;

    var a, b:integer; / / задаем переменные целого типа

    begin

    write (' введите час, когда исследователь лег спать '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите час, на который установлен будильник '); / / вводим с клавиатуры второе число

    read (b);

    if a > b / / проверяем условие

    then write (' будильник зазвонит через ', (12 - a + b), ' часов ') / / выводим один ответ

    else write (' будильник зазвонит через ', abs (a - b), ' часов '); / / иначе, выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Известный исследователь, устав от долгого путешествия по джунгли, лег спать в 10 часов вечера. Перед этим он завел будильник на 12 часов ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)
Дано натуральное число. Выведите его последнюю цифру. Входные данные Вводится единственное число (гарантируется, что оно не превышает 10000). Выходные данные Выведите ответ на задачу. Примеры входные данные 249 выходные данные 9
Ответы (1)
Дан массив, состоящий из целых чисел. Напишите программу, которая в данном массиве определит количество элементов, у которых два соседних и, при этом, оба соседних элемента меньше данного.
Ответы (1)
По данному натуральному n вычислите сумму 12+22 + ... + n2. Входные данные Вводится единственное натуральное число n, не превосходящее 100 Выходные данные Необходимо вывести вычисленную сумму. Примеры входные данные 2 выходные данные 5
Ответы (1)