Задать вопрос

12,277 Выяснить, есть ли в массиве строки, в которых буква A расположена справа от буквы d (известно, что буква d в каждой строке единственная).

+5
Ответы (1)
  1. 12 апреля, 10:11
    0
    В программе мы сначала проходим по массиву строк, рассматривая каждую строку, а затем проходим по каждой строке и ищем в ней сочетание 'da'.

    Если строка удовлетворяет условию - заносим ее в переменную words.

    var

    a: array[1 ... 2,1 ... 2] of string;

    word_, part, words:string;

    begin

    a[1,1]:='mother';

    a[1,2]:='coda';

    a[2,1]:='father';

    a[2,2]:='soda';

    for i:integer: = 1 to 2 do

    begin

    for j:integer: = 1 to 2 do

    begin

    write (a[i, j]:10);

    word_:=a[i, j];

    for m:integer: = 1 to length (word_) - 1 do

    if copy (word_, m, 2) = 'da' then

    words:=words+a[i, j]+' ';

    end;

    writeln ();

    end;

    writeln ('Слова, в которых буква а расположена справа от буквы d: ', words);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «12,277 Выяснить, есть ли в массиве строки, в которых буква A расположена справа от буквы d (известно, что буква d в каждой строке ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве B[5,6], значения элементов находятся в интервале [-25,30]. Подсчитать количество элементов, значение которых кратно 4. 2. В массиве C[6,10], значения элементов находятся в интервале [10,30], найти сумму элементов в 1 строке. 3.
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)
1. В массиве из 70 целых чисел найти количество элементов, кратных 3 2. Проверить, что в массиве ровно 3 одинаковых максимальных числа 3. В массиве удалить все элементы, имеющие нечетные значения
Ответы (1)
Составьте программу, выполняющую поиск минимального нечетного элемента в заданном целочисленном массиве из 50 элементов. Известно, что в массиве есть хотя бы один нечетный элемент.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)