Задать вопрос

С клавиатуры вводится предложение, в котором слова разделены пробелами. определите, сколько слов в этом предложении начинается на букву "а".

+2
Ответы (1)
  1. 10 октября, 20:29
    0
    Программа считает слова, которые начинаются с "а" и "А".

    program letter_a;

    var s: string;

    k: integer;

    begin

    writeln ('Введите несколько слов через пробел.');

    readln (s);

    k: = 0;

    for i:integer: = 1 to length (s) do

    begin

    //Если буква а в начале предложения

    if (i = 1) and ((s[1] = 'а') or (s[1] = 'А')) then k: = k + 1;

    //Если с буквы а начинается слово, и это слово не первое в предложении

    if (i > 1) and ((s[i - 1] + s[i] = ' а') or (s[i - 1] + s[i] = ' А')) then k: = k + 1;

    end;

    writeln ();

    writeln ('Количество слов, начинающихся с буквы "а" или "А": ', k)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «С клавиатуры вводится предложение, в котором слова разделены пробелами. определите, сколько слов в этом предложении начинается на букву "а". ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Нужно написать прогу в Pascal ABC. В заданном тексте заменить все слова A1 на слова A2 (слова в тексте разделены пробелами слова A1 и A2 вводятся с клавиатуры)
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1. Составьте программу, которая во введенном с клавиатуры слове заменит букву "А" на букву "И" и, наоборот, букву "И" на букву "А".
Ответы (1)
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Найти среднее арифметическое элементов последовательности, превосходящих некоторое число C. Массив задан с клавиатуры. Размер произвольный. Значение C вводится с клавиатуры.
Ответы (1)