Задать вопрос

Нужно написать прогу в Pascal ABC. В заданном тексте заменить все слова A1 на слова A2 (слова в тексте разделены пробелами слова A1 и A2 вводятся с клавиатуры)

+5
Ответы (1)
  1. 4 сентября, 11:36
    0
    program change;

    var a1, a2, s: string;

    k: integer;

    begin

    writeln ('Введите текст.');

    readln (s);

    writeln ();

    writeln ('Введите слово, которое надо заменить.');

    readln (a1);

    writeln ();

    writeln ('Введите слово, на которое надо заменитью');

    readln (a2);

    writeln ();

    while pos (a1, s) 0 do

    begin

    k: = pos (a1, s);

    delete (s, k, length (a1));

    insert (a2, s, k);

    end;

    writeln (s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нужно написать прогу в Pascal ABC. В заданном тексте заменить все слова A1 на слова A2 (слова в тексте разделены пробелами слова A1 и A2 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
С клавиатуры вводится предложение, в котором слова разделены пробелами. определите, сколько слов в этом предложении начинается на букву "а".
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
С клавиатуры вводятся числа от 1 до 9 до тех пор, пока не будет введен 0. Посчитайте количество единиц в этой последовательности, количество двоек, количество троек и так далее (программа должна вывести ровно 9 чисел).
Ответы (1)