Задать вопрос

Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел должно задаваться во время работы программы. (цикл для) (паскаль)

+2
Ответы (1)
  1. 7 октября, 07:21
    0
    Var n, i: integer;

    sr: real;

    a: array [1 ... 10000] of real;

    begin

    //запрос необходимых характеристик

    Write ('Введите количество чисел: '); Readln (n);

    Writeln ('Введите числа');

    For i:=1 to n do readln (a[i]);

    //вычисление среднего арифметического

    sr:=0;

    For i:=1 to n do sr:=sr+a[i];

    sr:=sr/n;

    //вывод

    Writeln ('Среднее арифметическое введённых чисел равно ', sr:4:3);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу, которая вычисляет среднее арифметическое вводимой с клавиатуры последовательности дробных чисел. Количество чисел ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Составить программу, которая вычисляет среднее арифметическое чисел. введенных с клавиатуры. Ввод чисел заканчивается, когда вводится 0. (на языке Паскаль)
Ответы (1)
написать программу, которая вычисляет сумму первых четных целых n положительных чисел, количество суммированных чисел должно вводиться во время работы программы.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
Написать программу, которая в одномерном массиве, заданном вводом с клавиатуры вычисляет среднее арифметическое массива без максимального и минимального элемента массива.
Ответы (1)