Задать вопрос

написать программу, которая вычисляет сумму первых четных целых n положительных чисел, количество суммированных чисел должно вводиться во время работы программы.

+5
Ответы (1)
  1. 4 апреля, 00:28
    0
    program sum_ch; / /Название программы.

    var n, sum, j, x: integer; / /Раздел описания переменных.

    begin / /Начало.

    writeln ('Введите количество суммированных чисел'); / /Запрос количества чисел.

    readln (n); / /Вводим с клавиатуры.

    while j < n do begin

    x : = x + 1;

    if x mod 2 = 0 then begin / /В этом условии проверяем на чётность.

    sum : = sum + x; / /Если чётное - тогда суммируем.

    j : = j + 1;

    end;

    end;

    writeln ('Сумма ', n, ' чётных чисел составляет ', sum); / /Выводим сумму.

    end. / /Конец.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «написать программу, которая вычисляет сумму первых четных целых n положительных чисел, количество суммированных чисел должно вводиться во ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале которая выводит на экран сумму первых n целых чисел. количество суммируемых чисел должно вводиться во время работы программы
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)