Задать вопрос
3 октября, 12:25

Массив целых чисел из 15 элементов. Заполнить случайным образом. Упорядочить массив по убыванию. Подсчитать количество элементов больше 10, вывести результат.

+3
Ответы (1)
  1. 3 октября, 13:18
    0
    Program sort;

    var

    A: array[1 ... 100] of integer;

    n, i, j, k, l: integer;

    begin

    randomize;

    n:=15;

    for i:=1 to n do A[i]:=random (100); {Заполняем массив случайными числами}

    for i:=1 to n do write (A[i],' '); {Массив рекомендуется выводить на экран для дальнейшего сравнения и контроля ошибок}

    writeln;

    k:=A[1];

    l:=0;

    for i:=1 to n-1 do {Сортировка методом пузырька}

    for j:=1 to n-i do

    if A[j]
    k:=A[j];

    A[j]:=A[j+1];

    A[j+1]:=k

    end;

    for i:=1 to n do if A[i]>10 then l:=l+1; {Подсчет элементов, больших 10}

    for i:=1 to n do write (A[i],' '); {Вывод на экран отсортированного массива}

    writeln;

    writeln ('Число элементов, больших 10: ', l)

    end.

    Один из методов сортировки - Метод пузырька. Сравниваются попарно элементы массива - 1 со 2, 2 с 3 и т. д. Задача - расположить элементы в порядке убывания, значит, если следующий элемент оказывается больше предыдущего, то мы меняем местами эти элементы, таким образом отодвигая большие числа влево, меньшие - вправо. И наименьший элемент окажется крайним справа. При следующем проходе уже не сравниваем последний и предпоследним, и наименьший из оставшихся окажется на предпоследнем месте.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Массив целых чисел из 15 элементов. Заполнить случайным образом. Упорядочить массив по убыванию. Подсчитать количество элементов больше 10, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1) Вывести массив 4*4 1 3 5 7 1 3 5 7 1 3 5 7 1 3 5 7 2) Массив 4*4 0010 0100 0000 1100 Подсчитать количество нулей и единиц 3) Случайным образом вывести массив 5*5 (50) A[I, j]: = random (50); Сумму элементов массива
Ответы (1)
Массив на 20 элементов заполнить случайным образом в диапозоне от - 5 до 10. Найти произведение всех значений. Подсчитать количество значений больше 3. Массив вывести в строку
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)