Задать вопрос

1) Вывести массив 4*4 1 3 5 7 1 3 5 7 1 3 5 7 1 3 5 7 2) Массив 4*4 0010 0100 0000 1100 Подсчитать количество нулей и единиц 3) Случайным образом вывести массив 5*5 (50) A[I, j]: = random (50); Сумму элементов массива

+5
Ответы (1)
  1. 23 ноября, 20:51
    0
    Задача 1.

    var

    arr: array[1 ... 4,1 ... 4] of real;

    begin

    writeln ('Наш массив:');

    for i:integer: = 1 to 4 do

    begin

    for j:integer: = 1 to 4 do

    begin

    if j=1 then

    arr[i, j] : = 1;

    if j=2 then

    arr[i, j] : = 3;

    if j=3 then

    arr[i, j] : = 5;

    if j=4 then

    arr[i, j] : = 7;

    write (arr[i, j]:5);

    end;

    writeln ();

    end;

    end.

    Задача 2.

    var

    arr: array[1 ... 4,1 ... 4] of integer;

    count_of_nul, count_of_ones:integer;

    begin

    writeln ('Наш массив:');

    arr[1,3]:=1;

    arr[2,2]:=1;

    arr[4,1]:=1;

    arr[4,2]:=1;

    for i:integer: = 1 to 4 do

    begin

    for j:integer: = 1 to 4 do

    begin

    if arr[i, j]=0 then

    count_of_nul:=count_of_nul+1

    else count_of_ones:=count_of_ones+1;

    write (arr[i, j]:5);

    end;

    writeln ();

    end;

    writeln ('Количество нулей: ', count_of_nul);

    writeln ('Количество единиц: ', count_of_ones);

    end.

    Задача 3.

    var

    a: array[1 ... 5,1 ... 5] of integer;

    count_of_el:integer;

    begin

    writeln ('Наш массив:');

    for i:integer: = 1 to 5 do

    begin

    for j:integer: = 1 to 5 do

    begin

    a[i, j]:=random (50);

    count_of_el:=count_of_el+a[i, j];

    write (a[i, j]:5);

    end;

    writeln ();

    end;

    writeln ('Сумма элементов массива: ', count_of_el);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Вывести массив 4*4 1 3 5 7 1 3 5 7 1 3 5 7 1 3 5 7 2) Массив 4*4 0010 0100 0000 1100 Подсчитать количество нулей и единиц 3) Случайным ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
Для генерации случайного целого числа из промежуток [10; 20) необходимо использовать выражение: а) random * 20 б) random (20) в) random (20) + 10 г) random (10) * 2
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)