Задать вопрос

Написать программу Паскаль, которая решает следующую задачу: телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп./мин. Разговоры длились t1, t2, t3 минут сооветственно. Какова общая стоимость разговоров?

+5
Ответы (1)
  1. 1 ноября, 02:10
    0
    var

    i, c, t, sum : integer; / / объявляем переменные вещественного типа.

    begin

    for i:=1 to 3 do / / начало цикла.

    begin

    writeln ('Введите длительность ', i,'-го разговора в минутах:'); / / вывод строки на экран.

    readln (t); / / считываем значение, введенное с клавиатуры.

    writeln ('Введите стоимость ', i,'-го разговора в коп/мин:'); / / вывод строки на экран.

    readln (c); / / считываем значение, введенное с клавиатуры.

    sum : = sum + t * c; / / считаем общую сумму разговоров.

    end;

    writeln ('Общая стоимость разговоров: ', sum, ' коп.'); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу Паскаль, которая решает следующую задачу: телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп./мин. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике