Задать вопрос

1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100? 2) какие значения может принимать целая переменная Y если в программе записано : Y : =10 + ranodom (5) ? 3) составьте программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве колличество положительных и колличество отрицательных значения

+4
Ответы (1)
  1. 2 декабря, 17:11
    0
    1)

    от 1 до 10 = random (11)

    от - 10 до + 10 = random (21) - 10

    от 50 до 100 = random (51) + 50

    2)

    от 10 до 14

    3) program zz1;

    const n = 100; / / задаем количество чисел в массиве

    var i, s, k:integer; / / задаем переменные целого типа

    m:array [1 ... n] of integer;

    begin

    for i:=1 to n do / / получаем n чисел случайных и записываем их в массив

    m[i]:=random (41) - 20;

    for i:=1 to n do / / организуем цикл, в котором переберем все числа массива

    begin

    if m[i] < 0 then s:=s + 1; / / проверяем, если очередной элемент массива отрицательный, то считаем его

    if m[i] > 0 then k:=k + 1; / / проверяем, если очередной элемент массива положительный, то считаем его

    end;

    writeln (' количество отрицательных элементов массива = ', s); / / выводим ответ

    writeln (' количество положительных элементов массива = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Как, используя функцию random (X), можно получать числа в диапазонах: от 1 до 10, от - 10 до + 10, от 50 до 100? 2) какие значения может ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Оставить программу заполнения массива из 100 чисел случайными значениями из диапозона от - 20 до 20. подсчитайте в этом массиве количество положительных и количество отрицательных значений.
Ответы (1)
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от - 20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений. (на паскале)
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
For i:=1 to N do Begin write ('C[', i,']='); readln (C[i]); end * Приведенный фрагмент программы, предназчен для 1 вывода массива в столбец 2 вывода массива в строку 3 формирования массива случайными числами 4 ввода массива с клавиатуры For i:=
Ответы (1)
Для генерации случайного целого числа из промежуток [10; 20) необходимо использовать выражение: а) random * 20 б) random (20) в) random (20) + 10 г) random (10) * 2
Ответы (1)