Задать вопрос
3 декабря, 04:58

Нужно написать программу на PascalABC. Вводится n чисел, найти максимальное двузначное среди них.

+1
Ответы (1)
  1. 3 декабря, 07:30
    0
    program zz1;

    var a, n, i, max : integer; / / задаем переменные целого типа

    begin

    write (' введите n '); / / вводим с клавиатуры количество чисел

    read (n);

    for i:=1 to n do / / организуем цикл на n повторений

    begin

    read (a); / / вводим очередное число

    if (a > 9) and (a < 100) then / / проверяем, если число двухзначное

    if a > max then max:=a; / / проверяем, если число больше максимального, то записываем его в максимальное

    end;

    write (' максимальное двухзначное число = ', max); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Нужно написать программу на PascalABC. Вводится n чисел, найти максимальное двузначное среди них. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы