Задать вопрос

Для генерации случайного целого числа из промежуток [10; 20) необходимо использовать выражение: а) random * 20 б) random (20) в) random (20) + 10 г) random (10) * 2

+1
Ответы (1)
  1. 15 ноября, 10:50
    0
    Вопрос поставлен некорректно - правильного ответа нет среди заданных. Такой диапазон случайных чисел получится лишь в том случае, если промежуток [0; 9] "передвинуть" на 10. [0 + 10; 19 + 10]. Получится [10; 20). Для генерации такого промежутка нужна функция random (10) + 10.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Для генерации случайного целого числа из промежуток [10; 20) необходимо использовать выражение: а) random * 20 б) random (20) в) random ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Закончите предложения. 1) Чтобы выбрать фоновый цвет, необходимо. 2) Чтобы выбрать основной цвет, необходимо. 3) Чтобы нарисовать прямоугольник, необходимо. 4) Чтобы нарисовать квадрат, необходимо. 5) Чтобы нарисовать овал, необходимо.
Ответы (2)
Вводятся величины X, Y целого типа. Написать программу для обмена значений величин. Необходимо использовать вспомогательную величину Т. Протестировать программу для X=5 и Y=-11.
Ответы (1)
Оператор mob (a, b) - находит остаток отделения целого числа а на целое число b, например:mob (25,4) = 1. Оператор div (a, b) - находит целую часть от деления целого числа а на целое число b, например:div (25,4) = 6.
Ответы (1)
Запишите функцию для получения случайного числа х из указанного промежутка. [0; 15) [0; 15] [-15; 15) 10; 15)
Ответы (1)
Var a:array[1 ... 10] of integer; i, m, max:integer; begin randomize; m:=0; for i:=1 to 10 do begin a[i] random (50); writeln ('a[', i,']=', a[i]); end; max:=a[1]; for i:=2 to 10 do if a[i]>max then max:=a[i];
Ответы (1)