Задать вопрос
12 января, 13:58

в паскале: По номеру дня недели вывести на печать рабочий это день или выходной, считая выходными субботу и воскресение

+4
Ответы (1)
  1. 12 января, 14:43
    0
    Дней в неделе всего семь. Нам понадобится массив из семи элементов строкового типа:

    var nedela : array [1 ... 7] of string;

    Начало программы:

    begin

    Массив должен быть заполнен названиями дней недели с понедельника до воскресенья включительно.

    Далее программа читает введенный номер недели:

    readln (nomer);

    Если номер равен 7 или 8, то на экран попадет запись о том, что этот день недели выходной:

    if (nomer = 7) or (nomer = 8) then

    writeln ('День недели ', nedela[nomer], ' выходной')

    Иначе на экран попадет запись о том, что этот день недели рабочий:

    else

    writeln ('День недели ', nedela[nomer], ' рабочий);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «в паскале: По номеру дня недели вывести на печать рабочий это день или выходной, считая выходными субботу и воскресение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Составить программу, которая по порядковому номеру дня недели выводит соответствующую фразу - "Суббота", "Воскресенье" или "Рабочий день"
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Написать программу которая по введенному номеру дня недели выдавал название дня
Ответы (1)