Задать вопрос

Заданы числа a и b. Если они положительные то найти их произведение а в остальных случаях найти их сумму.

+1
Ответы (1)
  1. program abc;

    var

    a, b, c: integer;

    begin

    readln (a);

    readln (b);

    if (a > 0) and (b > 0) then c : = a * b

    else c : = a + b;

    writeln (c);

    end.

    Код написан на языке Паскаль. Создаём переменные a, b, c. Считываем два числа и записываем их в переменные "a" и "b". Проверяем, являются ли оба числа положительными (т. е. больше нуля). Если да, то в переменную "c" записываем произведение, если нет, то - сумму. Выводим значение переменной "c".
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Заданы числа a и b. Если они положительные то найти их произведение а в остальных случаях найти их сумму. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано два числа. если числа четны, то вычислите их произведение, если числа не четны, то их сумму, в остальных случаях вычислите разность этих чисел.
Ответы (1)
Заданы массивы А и В из N чисел (N=10) Заданы массивы А и В из N чисел (N=10) случайным образом. Сформировать новый массив, каждый элемент которого равенСумме элементов этих массивов
Ответы (1)
Даны действительные числа x, y, z Если все числа положительны, увеличить их значения в 2 раза; во всех отальных случаях отрицательные числа заменить их модулями, а положительные оставить без изменения. (Надо написать программу на паскале)
Ответы (1)
1. Найти значение Y, которое равно квадрату заданного числа Х, если Х>2, и равно 4 в остальных случаях. 2. Найти значение Y при заданном X : 3X+9, если X7
Ответы (1)
Дан массив в котором есть положительные и отрицательные числа. Найти отдельно сумму положительных чисел и сумму отрицательных чисел.
Ответы (1)