Задать вопрос
29 сентября, 15:59

Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу: НОД (А, B, С) = НОД (НОД (A, В), С). Используя алгоритм Евклида.

+3
Ответы (1)
  1. 29 сентября, 17:36
    0
    Program zz1;

    Var a, b, c:integer; / / задаем переменные целого типа

    Function Nod (a, b:integer) : integer; / / вспомогательный алгоритм

    Begin

    While ab do / / организуем цикл, используем алгоритм Евклида

    if a>b / / проверяем условие, если первое число больше второго

    then a:=a-b / / то, от первого отнимаем второе

    else b:=b-a; / / иначе, от второго отнимаем первое

    Nod:=a; / / в связи с тем, что по окончании цикла два числа сравняются, ответом является любое из них

    End;

    begin

    write (' Введите три числа '); / / вводим с клавиатуры три заданных числа

    readln (a, b, c);

    writeln (' НОД трех чисел = ', Nod (Nod (a, b), c));

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу: НОД (А, B, С) = НОД (НОД (A, В), С). ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы