Задать вопрос

Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить: a) Через сколько дней он будет пробегать не более 20 км? б) Сколько километров он пробежит на 7-ой день?

+4
Ответы (1)
  1. 15 апреля, 06:58
    0
    Program Primer1;

    Var

    i: integer;

    d, s: real;

    begin

    d : = 10; { пробег за 1 день}

    s : = 10; {сумма пробега за 1 день}

    for i : = 2 to 7 do

    begin

    d: = d * 1.1; {пробег за каждый следующий день}

    s: = s + d; {сумма пробега}

    end;

    writeln ('за 7 день-', s); {пробег за 7 день}

    end.

    За 2 день спортсмен пробегает 11 км, поэтому не более 20 км он пробежит за 1 день.

    За 30 и далее км можно вставить строку в цикл

    if s < 30 then writeln ('за ', i, 'день');
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Начав тренировки спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10 процентов от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней
Ответы (1)
Паскаль: Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня.
Ответы (1)
1) Спортсмен пробежал 10 км за 1 день каждый следующий день он пробегает на 10% больше сколько он пробежит за N дней!2) Найти количество делителей у n числа! Pascal
Ответы (1)
Turbo Pascal. Написать программу ... Каков будет пробег спортсмена на N-й день, если в первый день Х км и каждый следующий день на 10% больше чем в предыдущем.
Ответы (1)
Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней
Ответы (1)