Задать вопрос

Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем в предыдущий. Сколько километров он пробежит в 10-й день? Найти общую сумму пробега за 10 дней

+1
Ответы (1)
  1. 14 ноября, 12:59
    0
    var

    i, x, y : integer; / / объявляем переменные целочисленного типа.

    begin

    x : = 5; / / пробег спортсмена в первый день.

    for i : = 2 to 10 do / / в цикле считаем пробег со 2-го по 10-й день.

    begin

    x : = x + 10; / / увеличиваем пробег за каждый день на 10 км.

    if i = 10 then writeln ('За 10-й день спортсмен пробежал: ', x,' км.'); / / пробег за 10-й день.

    y : = y + x; / / считаем общую сумму пробега за 10 дней.

    end;

    writeln ('Сумма пробега спортсмена за 10 дней составляет: ', y + 5,' км.'); / / вывод ответа.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу решения задачи: Спортсмен в первый день пробегает 5 километров, а в каждый следующий день на 10 километров больше, чем ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Нужна помощь, очень прошу! Помогите составить алгоритм: спортсмен тренировался 7 дней, в первый день он пробегает 1000 м, в каждый следующий на 10 % больше, чем в предидущий. Сколько сумарно он пробежит за 7 дней?
Ответы (1)
1) Спортсмен пробежал 10 км за 1 день каждый следующий день он пробегает на 10% больше сколько он пробежит за N дней!2) Найти количество делителей у n числа! Pascal
Ответы (1)
Начав тренировки спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал дневную норму на 10 процентов от нормы предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней
Ответы (1)
Turbo Pascal. Спортсмен пробежал 10 км в первый день. Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить: a) Через сколько дней он будет пробегать не более 20 км? б) Сколько километров он пробежит на 7-ой день?
Ответы (1)
2. Составить программу к следующей задаче: "Американский дедушка, подарил своему внуку на 1 день рождения 1$. Каждый следующий день рождения он удваивал свой предыдущий подарок и прибавлял к нему сколько долларов, сколько лет исполнялось внуку.
Ответы (1)