Задать вопрос
22 января, 23:17

Программа для Pascal ABC С клавиатуры вводится 2 числа, если они оба четные, то найти их разность, иначе вычислить сумму модулей

+3
Ответы (1)
  1. 22 января, 23:30
    0
    Program proverka_chetnosty;

    var a, b, rez: integer; / / / Ввели целочисленные переменные: два числа и результат

    begin

    writeln ('Введите два числа'); / / / Сообщение выводится на экран

    readln (a, b); / / / Программа присвоила введенные числа переменным a и b

    begin

    if (a mod 2 = 0) and (b mod 2 = 0) then / / / Если оба числа четны, то

    rez : = abs (b - a) / / / результатом будет являться модуль их разности

    else rez : = abs (a) + abs (b); / / / иначе результатом будет являться сумма их модулей

    end;

    writeln (rez); / / / Вывод результата на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Программа для Pascal ABC С клавиатуры вводится 2 числа, если они оба четные, то найти их разность, иначе вычислить сумму модулей ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Работа в экселе. Даны два числа. Если оба чётные, то вывести слово "чётные". Если оба числа нечётные, то вывести слово "нечётные", иначе (одно чётное, другое-нечётное) вывести их произведение.
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
С клавиатуры вводится 2 числа, если они оба больше 5, то найти их полусумму, иначе удвоенное произведение.
Ответы (1)
Вычислите сумму данных N натуральных чисел. Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить. Выходные данные Выведите единственное число - сумму введенных чисел. В Pascal ABC
Ответы (1)
Задача через паскаль АБС ввести с клавиатуры 4 числа если 1 и 2 оканчивается на 5, то увеличить каждое из этих чисел в 2 раза иначе уменьшить каждое из чисел на 5 если 3 и 4 число нечётные, то вычислить сумму квадратов этих чисел иначе их
Ответы (1)