Задать вопрос

Вычислить сумму чисел от 10 до 70, чисел кратных 4

+3
Ответы (1)
  1. 5 октября, 00:42
    0
    Решим задачу, составив программу на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s - сумма чисел ряда, которую надо найти, а х - числа от 10 до 70. Начальное значение суммы s будет равным нулю. Так как чисел много, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 10. Последнее слагаемое в сумме - число 70.

    Программа может выглядеть так:

    program zadacha;

    uses crt;

    var s, i: integer;

    begin

    s:=0; {Задание начального значение суммы s}

    for i:=10 to 70 do begin

    if i mod 4=0 {Поиск чисел, кратных 4}

    then s:=s+i; {Вычисление суммы чисел, кратных 4}

    end;

    writeln ('s=', s) {Вывод результата суммы s чисел, кратных 4}

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму чисел от 10 до 70, чисел кратных 4 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
1. найти сумму первых 10 чисел, кратных 7; 2. вывести на экран 11 первых чисел кратных 5; 3. составить программу рисования 18 прямоугольников синего цвета, координаты которых определяется случайным образом, а стороны равны а=140, b=40.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4.
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)