Задать вопрос

Составить программу, которая заменяет в введенном с клавиатуры предложении все буквы с "Б" на "П"

+3
Ответы (1)
  1. 20 ноября, 19:27
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    read (s); / / вводим с клавиатуры строку

    for i:=1 to length (s) do / / организуем цикл, в котором переберем все символы от первого до последнего

    begin

    if s[i] = 'Б' then begin delete (s, i, 1); insert ('П', s, i); end; / / производим замену

    end;

    write (' полученная строка = ', s);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составить программу, которая заменяет в введенном с клавиатуры предложении все буквы с "Б" на "П" ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы