Задать вопрос

Составьте программу на языке паскаль которая в зависимости от введенного символа c, s, w программа вычисляет длину окружности, площадь круга или обьем цилинра.

+2
Ответы (1)
  1. 1 декабря, 04:50
    0
    program calc;

    uses crt;

    var s: char;

    r, d, h: real;

    begin

    repeat

    ClrScr;

    writeln ();

    writeln ('Вычислить:');

    writeln ('длину окружности: с');

    writeln ('площадь круга: s');

    writeln ('объем цилиндра: w');

    writeln ('Выйти из программы: z');

    readln (s);

    case s of

    'c': begin

    writeln ('Радиус окружности: ');

    readln (r);

    Writeln ('Длина окружности: ', (2 * pi * r) : 6 : 2)

    end;

    's': begin

    writeln ('Радиус круга: ');

    readln (r);

    Writeln ('Площадь круга: ', (2 * pi * r) : 6 : 2)

    end;

    'w': begin

    writeln ('Диаметр и высота цилиндра через пробел: ');

    readln (d, h);

    Writeln ('Объем цилиндра: ', ((pi * d * d * h) / 4) : 6:2)

    end

    end;

    writeln ('Продолжение - Ентер');

    readln ();

    until s = 'z'

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составьте программу на языке паскаль которая в зависимости от введенного символа c, s, w программа вычисляет длину окружности, площадь ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы