Задать вопрос

Напишите программу в паскаль, которая вычисляет площадь кольца если его толщина t см а диаметр внутреннего круга - d см

+2
Ответы (1)
  1. 28 декабря, 20:55
    0
    Площадь кольца равна разности площадей внешнего и внутреннего круга с диаметрами D и d.

    В нашем случае D = d + 2 * t.

    Площадь круга с диаметром кольца d + 2*t равна:

    S = (pi * (d + 2 * t) ^2) / 4.

    Площадь внутреннего круга:

    s = (pi * d^2) / 4.

    Формула для использования в программе:

    pi * (d + 2*t) ^2) / 4 - (pi * d^2) / 4 = pi * ((d + 2 * t) ^2 - d^2) / 4.

    program ring;

    const pi = 3.1416;

    var d, t: real;

    begin

    writeln ('Введите диаметр внутреннего круга кольца в сантиметрах');

    readln (d);

    writeln ('Введите толщину кольца в сантиметрах');

    readln (t);

    writeln ('Площадь кольца = ', pi * (power (d + 2 * t, 2) - power (d, 2)) / 4, ' см');

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Напишите программу в паскаль, которая вычисляет площадь кольца если его толщина t см а диаметр внутреннего круга - d см ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Напишите программу которая вычисляет площадь кольца, если его толщина t см, а диаметр внутреннего круга-d см (в паскале)
Ответы (1)
1) Напишите программу, которая определяет, является ли число нечётным. 2) Напишите программу, которая вычисляет сумму всех чётных чисел в диапазоне от 1 до n.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)
Составьте программу на языке паскаль которая в зависимости от введенного символа c, s, w программа вычисляет длину окружности, площадь круга или обьем цилинра.
Ответы (1)
Наибольший общий делитель (НОД) двух или нескольких чисел - это наибольшее число, на которое делятся все заданные числа. Напишите программу, которая вычисляет НОД двух чисел. Используйте функцию. Паскаль ABC
Ответы (1)