Задать вопрос

Числовой ряд из 10 чисел задается генератором случайных чисел в диапазоне от 1 до 20. Найти насколько сумма четных отличается от суммы нечетных.

+2
Ответы (1)
  1. 8 июля, 01:40
    0
    Задание выполнено на ЯПВУ Паскаль. Ключевый действия описаны в коде в виде комментариев (т. е. отделены от основного кода символами "//"). При подсчете сумм используется функция "остаток целочисленного деления" - mod. Если остаток деления на 2 равно 1, то число нечетное, если 0 - то четное.

    var

    m:array[1 ... 10] of integer; //объявление массива

    i, s1, s2, s:integer; //объявление необходимых переменных

    begin

    randomize; //запус генератора случайных чисел

    for i:=1 to 10 do / /цикл-счетчик для заполнения массива

    begin

    m[i]:=random (20); //элементу массива задается случайное значение

    write (m[i],' ');

    end;

    for i:=1 to 10 do//цикл-счетчик подсчета сумм

    begin

    if m[i] mod 2 = 1 then s1:=s1+m[i]; //проверка на четность, вычисление суммы нечетных

    if m[i] mod 2 = 0 then s2:=s2+m[i]; //проверка на четность, вычисление суммы четных

    end;

    s:=abs (s1-s2);

    write ('Суммы четных и нечетных отличаются на ', s); //вывод результата на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Числовой ряд из 10 чисел задается генератором случайных чисел в диапазоне от 1 до 20. Найти насколько сумма четных отличается от суммы ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Числовой ряд из 10 чисел задаётся генератором случайных чисел в диапазоне от 1 до 20. Найти сумму чисел, кратных 4
Ответы (1)
А) Вывести на экран квадрат первых двадцати нечетных чисел. Б) Найти сумму n четных чисел, количество четных чисел задается в процессе работы программы.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)
Дано N случайных чисел в диапазоне от - 3 до 3. Вычислите, сколько из них не совпадают с 0. Составить программу, используя цикл for. Для задания случайных ч исел используйте функцию random. N определяет пользователь. Числа вывести на экран.
Ответы (1)
генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел. составьте программу, с помощью которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами
Ответы (1)