Задать вопрос

ввести 3 стороны треугольника, вывести его площадь. (на языке паскаль) ввести число, вывести квалратный корень.

+3
Ответы (1)
  1. 7 февраля, 14:51
    0
    program zz1;

    var a, b, c, S, p, d:real; / /задаем переменные не целого типа

    begin

    write ('введите первую сторону треугольника ');

    read (a);

    write ('введите вторую сторону треугольника ');

    read (b);

    write ('введите третью сторону треугольника ');

    read (c);

    d: = (a+b+c) / 2; / /находим полупериметр треугольника

    if (a+b>c) or (a+c>b) or (c+b>a) / /проверяем на существование треугольника, если существует, то вычисляем площадь

    then begin s:=sqrt (d * (d-a) * (d-b) * (d-c)); write ('площадь треугольника = ', s:5:2); end

    else write ('треугольник не существует ');

    writeln;

    write ('введите число ');

    read (a);

    write (' квадратный корень числа = ', sqrt (a));

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «ввести 3 стороны треугольника, вывести его площадь. (на языке паскаль) ввести число, вывести квалратный корень. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Ввести число от 5 до 9. Вывести его значение словом. Составить программу для решения приведенного ниже задания двумя способами, используя: а) команду выбора case; б) команду if. Ввести число от 5 до 9. Вывести его значение словом.
Ответы (1)
Ввести 2 числа используя оператор ввода данных read (). Перед оператором read () обязательно вывести объяснения значения какой переменной надо ввести (Например, writeln ('vvedite a'); ). Ввести их через запятую.
Ответы (1)
1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3.
Ответы (1)
1) Вывести массив A (N). Вывести на печать данные о числе нулевых элементов массива и их номера. Если таковых нет, вывести на печать сообщение об этом 2) Вывести массив А (N, N). Разделить все его элементы на минимальный элемент главной диагонали.
Ответы (1)