Задать вопрос

Написать программу в паскале которая выводит на экран сумму первых n целых чисел. количество суммируемых чисел должно вводиться во время работы программы

+3
Ответы (1)
  1. 15 мая, 09:37
    0
    program zz1;

    var n, i, s:integer; / / задаем переменные целого типа

    begin

    write (' введите количество суммируемых чисел n '); / / вводим заданное количество чисел

    read (n);

    for i:=1 to n do / / организуем цикл, в котором переберем все числа от единицы до заданного n

    s:=s + i; / / находим сумму натуральных чисел, прибавляя очередное число из цикла к сумме

    writeln (' сумма первых n целых чисел = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу в паскале которая выводит на экран сумму первых n целых чисел. количество суммируемых чисел должно вводиться во время ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая вводит массив из 10 целых чисел и выводит на экран этот же массив в прямом и обратном порядке.
Ответы (1)
написать программу, которая вычисляет сумму первых четных целых n положительных чисел, количество суммированных чисел должно вводиться во время работы программы.
Ответы (1)
В массиве хранятся сведения о количестве осадков, выпавших за 10 дней июня. Написать программу, которая определяет общее количество осадков за 10 дней. Массив должен вводиться во время работы программы.
Ответы (1)
Составить на Паскале программу, которая по введённому номеру месяца выводит название времени года. При написании программы использовать логические операции.
Ответы (1)
Написать программу на паскале, которая вводит массив из N целых случайных чисел, лежащих в диапазоне от 10 до 99 и выводит на экран элементы, кратные числу K.
Ответы (1)