Задать вопрос
2 апреля, 00:03

Составит программу, которая в строке S находит количество а и о и вычёркивает все буквы м

+1
Ответы (1)
  1. 2 апреля, 01:05
    0
    program zz1;

    var s:string; / / задаем переменную строкового типа

    k, i:integer; / / задаем переменную целого типа

    begin

    write (' введите строку ');

    readln (s); / / вводим с клавиатуры заданную строку

    for i:=length (s) downto 1 do

    begin

    if (s[i] = 'а') or (s[i] = 'о') then k:=k + 1; / / считаем количество букв

    if s[i] = 'м' then delete (s, i, 1); / / удаляем м

    end;

    writeln (' количество букв а и о = ', k); / / выводим один ответ

    write (' строка после удаления из нее м = ', s); / / выводим другой ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Составит программу, которая в строке S находит количество а и о и вычёркивает все буквы м ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Написать программу, которая находит в массиве случайных символов первое вхождение заданного символа.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)
Составьте программу которая заполняет массив b 1 ... 8 случайными целыми числами в диапазоне от 1 до 10 и находит количество пар элементов с чётными значениями пример ввода: исходный массив: 10 2 4 1 3 5 7 8 количество пар чётных элементов =
Ответы (1)