Задать вопрос

Вычислить сумму натуральных чисел от 1 до N. Составить программу нахождения кол-ва делителей числа N (значение N вводится с клавиатуры)

+2
Ответы (1)
  1. 18 октября, 18:38
    0
    program zz1;

    var n, i, s, k:integer; / / вводим переменные целого типа

    begin

    write (' введите число '); / / вводим с клавиатуры число

    read (n);

    for i:=1 to n do / / организуем цикл, в котором переберем все числа от 1 до n

    begin

    s: = s + i; / / высчитываем сумму

    if n mod i = 0 then k:=k + 1; / / считаем количество делителей

    end;

    writeln (' сумма чисел от 1 до n = ', s); / / выводим ответ

    writeln (' количество делителей числа n = ', k);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Вычислить сумму натуральных чисел от 1 до N. Составить программу нахождения кол-ва делителей числа N (значение N вводится с клавиатуры) ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1). Составить программу, которая выводит на экран сумму, произведение и средние арифметическое кубов всех целых чисел от a до, b. (Значение переменных a и b вводится с клавиатуры). 2).
Ответы (1)
Напечатать "столбиком": а) все целые числа от 20 до 35; б) квадраты всех целых чисел от 10 до b (значение b вводится с клавиатуры; b > (или равно) 10); в) третьи степени всех целых чисел от a до 50 (значение а вводится с клавиатуры; а (или равно) а).
Ответы (1)
1. Составить программу для нахождения площади трапеции. 2. Составить программу для нахождения квадрата суммы двух чисел (по формулам сокращённого умножения). 3.
Ответы (1)
1) Составить программу нахождения суммы квадратов чисел от 25 до 125. 2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=
Ответы (1)
1. Составте программу для нахождения граммов G в X унциях (1 унция = 28,35 грамма). Исходное количиство граммов задается с клавиатуры. 2. Напишите программу нахождения длин медиан m1, m2 и m3 треугольника по указанным формулам.
Ответы (1)