Задать вопрос
14 марта, 15:55

Дано натуральное число. определить сумму его цифр, больших 5

+1
Ответы (1)
  1. 14 марта, 17:06
    0
    program zz1;

    var s, n, k:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число ');

    read (n); / / вводим с клавиатуры число

    s:=0; / / задаем начальное значение для количества

    while n>0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру

    if k > 5 then s:=s + k; / / проверяем больше она 5 и считаем ее

    n:=n div 10; / / отбрасываем последнюю цифру из числа

    end;

    writeln (' сумма цифр в числе больших 5 = ', s); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число. определить сумму его цифр, больших 5 ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
Дано натуральное число n. Определить: a) Количество цифр в этом числе; б) Сумму его цифр; в) Первую цифру числа n;
Ответы (1)
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)