Задать вопрос
24 октября, 08:25

1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются. (например, число 1379 перепишем как 8679) 2) Триморфное число - число, запись куба которого оканчивается цифрами самого этого числа. Например, 43 = 64, 243 = 13 824, 2493 = 15 438 249. определить, является ли введенное число тримоформным.

+4
Ответы (1)
  1. 24 октября, 09:41
    0
    1) program zz1;

    var a, k, i, s, n:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное k ');

    read (k);

    s:=0;

    while k0 do

    begin

    a:=k mod 10;

    if a = 0 then s:=s*10+9;

    if a = 1 then s:=s*10+8;

    if a = 2 then s:=s*10+7;

    if a = 3 then s:=s*10+6;

    if a = 4 then s:=s*10+5;

    if a = 5 then s:=s*10+5;

    if a = 6 then s:=s*10+6;

    if a = 7 then s:=s*10+7;

    if a = 8 then s:=s*10+8;

    if a = 9 then s:=s*10+9;

    k:=k div 10;

    end;

    while s0 do / / переворачиваем полученное число

    begin

    a:=s mod 10;

    s:=s div 10;

    n:=n * 10 + a;

    end;

    writeln ('полученное новое число = ', n); / / выводим ответ

    end.

    2) program zz1;

    var a, k, i, s, n:integer; / / задаем переменные целого типа

    begin

    write (' введите заданное k ');

    read (k);

    s:=1;

    a:=k;

    while k0 do

    begin

    k:=k div 10;

    n:=n + 1;

    end;

    for i:=1 to n do

    s:=s*10;

    if (a*a*a) mod s = a then write (' число тримоформное ') else write (' число не тримоформное '); / / выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Дано число. Получить новое число с обратным значением цифр, где 0→9, 1→8, 2→7, 3→6, 4→5, а цифры 5, 6,7,8,9 не изменяются. (например, ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1) Дано натуральное число. Получить новое, приписав к нему такое же число (например, дано число 234, результат - 234234) 2) Автоморфным называется число, цифры которого совпадают с последними цифрами его квадрата.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1) Сколько значащих нулей в двоичной записи десятичного числа 503? 2). Для каждого из перечисленных ниже десятичных чисел построили двоичную запись. Укажите число, двоичная запись которого содержит наибольшее количество значащих нулей.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)