Задать вопрос

Даны три целых числа. Написать программу, выводящую те из них, которые больше нуля, и подсчитывающую их произведение

+3
Ответы (1)
  1. 24 января, 22:10
    0
    program zz1;

    var a, b, c:integer; / / вводим переменные целого типа

    begin

    write (' введите первое число '); / / вводим с клавиатуры первое число

    read (a);

    write (' введите второе число '); / / вводим с клавиатуры второе число

    read (b);

    write (' введите третье число '); / / вводим с клавиатуры третье число

    read (c);

    if a > 0 then write (a, ' '); / / проверяем на положительность введенные числа

    if b > 0 then write (b, ' ');

    if c > 0 then writeln (c, ' ');

    / / выводим ответ

    write (' произведение чисел ', a * b * c);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Даны три целых числа. Написать программу, выводящую те из них, которые больше нуля, и подсчитывающую их произведение ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы