Задать вопрос
17 июня, 21:17

Найти сумму целых чисел от 1 до 200, у которых ровно 5 делителей

+4
Ответы (1)
  1. 17 июня, 21:26
    0
    Программа выводит сумму чисел и их делители.

    program dividers_5;

    var l, s: integer;

    begin

    l:=0;

    for i:integer:=1 to 200 do

    begin

    for k:integer:=1 to i do if i mod k = 0 then l:=l+1;

    if l=5 then

    begin

    write ('Число: ', i : 8, '.');

    s: = s + i;

    write (' Делители: ');

    for k:integer:=1 to i do if i mod k = 0 then write (k:4);

    writeln ()

    end;

    l:=0

    end;

    writeln ('Сумма чисел: ', s)

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Найти сумму целых чисел от 1 до 200, у которых ровно 5 делителей ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
3. Дано натуральное число. Найти сумму его четных делителей и количество этих делителей.
Ответы (1)
Напишите программу, которая запрашивает четыре целых числа и выдает на экран: 1) сумму чисел; 2) сумму квадратов чисел; 3) среднее арифметическое чисел; 4) сумму парных произведений.
Ответы (1)
В одной книге было написано 100 следующих утверждений. "В этой книге ровно одно неверное утверждение" "В этой книге ровно два неверных утверждения" "В этой книге ровно сто неверных утверждений" Какой из них правильный?
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов2) Дан массив целых чисел.
Ответы (1)