Задать вопрос

В паскале. В массиве из 10 целых чисел определить, сколько значений превышает число 3.

+5
Ответы (1)
  1. 14 июня, 15:15
    0
    var

    i, x : integer; / / объявляем переменные целочисленного типа.

    arr : array [1 ... 10] of integer; / / объявляем массив.

    s : string; / / объявляем переменную строкового типа.

    Begin

    for i : = 1 to 10 do / / начало цикла.

    begin

    arr[i] : = random (-100, 100); / / заполняем массив числами из диапазона - 100; 100.

    s : = s + arr[i] + ' '; / / записываем элементы массива в одну строку.

    if (arr[i] > 3) then x : = x + 1; / /считаем количество элементов массива больше трёх.

    end;

    write ('Массив: ', s); / / вывод массива на экран.

    writeln; / / переход на следующую строку.

    write ('Количество элементов в массиве больше трех равно: ', x); / /вывод на экран строки.

    End.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «В паскале. В массиве из 10 целых чисел определить, сколько значений превышает число 3. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. В массиве из 70 целых чисел найти количество элементов, кратных 3 2. Проверить, что в массиве ровно 3 одинаковых максимальных числа 3. В массиве удалить все элементы, имеющие нечетные значения
Ответы (1)
Написать программу в Паскале: В массиве из N действительных чисел, введённых с клавиатуры, найти номер первого отрицательного элемента и выдать на экран этот элемент или сообщение о том, что в массиве отрицательных элементов нет.
Ответы (1)
1. В массиве а1, а2, ..., а50 определить количество нулей 2. В массиве с1, с2, ..., с40 найти сумму чисел больших единицы 3. Дана последовательность чисел d1, d2, ..., d50 определить минимальный элемент
Ответы (1)
На Паскале. Задан массив из N действительных чисел (N может быть задано не более 25). Отрицательные числа в заданном массиве упорядочить по убыванию их значений. Взаимное расположение отрицательных и положительных чисел сохранить.
Ответы (1)
Вводится массив, состоящий из целых чисел. Найти наибольшее среди них. Входные данные Сначала задано число N - количество элементов в массиве (1N35). Далее через пробел записаны N чисел - элементы массива. Массив состоит из целых чисел.
Ответы (1)