Задать вопрос

1) Найдите сумму и произведение целых чисел больших 13 и меньших 100 и кратных 4.

+4
Ответы (1)
  1. 17 февраля, 01:18
    0
    var

    numbers, sum_of_numbers, mult_of_numbers:integer;

    begin

    for i:integer:=14 to 99 do

    begin

    Проверяем числа от 14 до 99 на кратность 4, то есть остаток от деления на 4 будет равен нулю:

    if i mod 4 = 0 then

    Наращиваем переменную для суммы:

    sum_of_numbers:=sum_of_numbers+i

    end;

    mult_of_numbers:=1;

    for i:integer:=14 to 99 do

    begin

    if i mod 4 = 0 then

    begin

    Увеличиваем переменную для произведения:

    mult_of_numbers:=mult_of_numbers*i;

    end; end;

    Выводим на экран два числа:

    writeln ('Число А: ', sum_of_numbers);

    writeln ('Число B: ', mult_of_numbers);

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «1) Найдите сумму и произведение целых чисел больших 13 и меньших 100 и кратных 4. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
1. Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел.
Ответы (1)
Найти произведение и сумму чисел больших 100 и меньших 200 и кратных 5 на языке программирования Pascal. Следующими способами: While, For, Repeat.
Ответы (1)
Найти сумму целых положительных чисел, больших 20, меньших 120 и кратных 9 и не заканчивающих на 5
Ответы (1)
Напишите программу, которая в последовательности из 10 натуральных чисел определяет сумму чисел определяет сумму чисел, кратных 5. в последовательности всегда имеется число, кратное 5 программа должна вывести одно число сумму чисел кратных 5
Ответы (1)
Напишите программу, которая находит количество чисел, кратных 3, но не кратных 6, в последовательности целых чисел, вводимых клавиатуры. Признак конца ввода чисел 0. Количество введенных чисел заранее неизвестно.
Ответы (1)