Задать вопрос

Дано натуральное число. Верно ли, что сумма его цифр больше 10? Paskal

+1
Ответы (1)
  1. 27 октября, 08:39
    0
    program zz1;

    var s, n, k:integer; / / задаем переменные целого типа

    begin

    write (' введите натуральное число ');

    read (n); / / вводим с клавиатуры число

    s:=0; / / задаем начальное значение для количества

    while n>0 do / / организуем цикл, пока в числе есть цифры

    begin

    k:=n mod 10; / / получаем последнюю цифру

    s:=s + k; / / добавляем ее к сумме

    n:=n div 10; / / отбрасываем последнюю цифру из числа

    end;

    if s > 10 then write (' верно ') else write (' не верно'); / / проверяем сумму цифр и выводим ответ

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Дано натуральное число. Верно ли, что сумма его цифр больше 10? Paskal ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Найти разность и частное его цифр. 2. Дано целое число. Если оно является положительным то прибавить к нему 1. Емли нулевым то заменить его на 10. 3. Дано двузначное число. Вывести его левую цифру, потом правую. 4.
Ответы (1)
Напишите программу поиска всех трёхзначных чисел, сумма цифр которых и само число кратны 7 Paskal
Ответы (1)
1) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. 2) Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры (не обязательно стоящие рядом).
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)