Задать вопрос

Ан массив целых чисел n=14 заполненный случайным образом числами из промежутка [-15 30] 1) удалить последний четный элемент 2) поменять местами первую и вторую его половины.

+3
Ответы (1)
  1. 21 августа, 02:38
    0
    Задание выполнено на ЯПВУ Паскаль. Ключевые моменты описаны в виде комментариев, отделенных от основного кода символами "//".

    const

    n=14;

    var

    m:array[1 ... n] of integer; //объявление массива

    i, z, o:integer; //объявление необходимых переменных

    begin

    randomize; //запуск генератора случайных чисел

    for i:=1 to n do / /цикл-счетчик для заполнения массива

    begin

    m[i]:=random (45) - 15; //элементу массива задается случайное значение

    write (m[i],' ');

    end;

    writeln;

    i:=n+1;

    repeat//цикл поиска четного значения, и запись его номера

    i:=i-1;

    if m[i] mod 2 = 0 then z:=i;

    until m[i] mod 2 = 0;

    if z
    for i:=1 to z div 2 do / /цикл-счетчик замены половин массива

    begin

    o:=m[i];

    m[i]:=m[z+1-i];

    m[z+1-i]:=o;

    end;

    for i:=1 to z do write (m[i],' '); //вывод результата на экран

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Ан массив целых чисел n=14 заполненный случайным образом числами из промежутка [-15 30] 1) удалить последний четный элемент 2) поменять ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Дан одномерный массив целых чисел, заполненный случайным образом числами из промежутка [-40, 30]. Массив данных хранится в файле. Удалить из него все элементы, которые состоят из одинаковых цифр. Результат записать в другой файл.
Ответы (1)
1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива. 2.
Ответы (1)
Дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых цифр (включая однозначные числа). 2.
Ответы (1)
Дан массив целых чисел a (n) (n=15) заполненный случайным образом числами из промежутка [-20,50]. Заменить нулем четные по значению элементы данного массива
Ответы (1)
написать программу на Pascal - В одномерном массиве целых чисел, содержащем 20 элементов, удалить k-ый элемент массива. Массив заполняется случайным образом числами от 0 до 50.
Ответы (1)