Задать вопрос

Написать программу. Дано четырехзначное число. Определить, равен ли квадрат первой цифры кубу третьей цифры этого числа.

+4
Ответы (1)
  1. 13 февраля, 07:34
    0
    var

    a, b, s, s1, i: integer; / / объявляем переменные целочисленного типа.

    begin

    write ('Введите четырехзначное число:'); / / вывод строки на экран.

    read (a); / / считываем число, введенное с клавиатуры.

    while a > 0 do / / начало цикла.

    begin

    b : = a mod 10; / / определяем последнюю цифру числа.

    if i = 1 then s : = b; / / запоминаем третью цифру.

    if i = 3 then s1 : = b; / / запоминаем первую цифру.

    a : = a div 10; / / удаляем последнюю цифру из числа.

    i : = i + 1; / / счетчик цифр.

    end;

    if (power (s1,2) = power (s, 3)) then / / сравниваем квадрат первой цифры и куб третьей цифры.

    writeln ('Квадрат ', s1, ' равен кубу ', s) / / вывод на экран строки.

    else

    writeln ('Квадрат ', s1, ' не равен кубу ', s); / / вывод строки на экран.

    end.
Знаешь ответ на этот вопрос?
Сомневаешься в правильности ответа?
Получи верный ответ на вопрос 🏆 «Написать программу. Дано четырехзначное число. Определить, равен ли квадрат первой цифры кубу третьей цифры этого числа. ...» по предмету 📕 Информатика, используя встроенную систему поиска. Наша обширная база готовых ответов поможет тебе получить необходимые сведения!
Найти готовые ответы
Похожие вопросы информатике
Написать программу в паскале: Дано трехзначное число. Найти число, полученное перестановкой первой и третьей цифры заданного числа.
Ответы (1)
написать программу на языке паскаля 1) Дано натуральное число. Определить является ли оно чётным 2) дано натуральное число. Определить оканчивается ли оно цифрой 7.
Ответы (1)
1. Даны два различных вещественных числа X и Y. Написать программу, возведения наименьшего из чисел в квадрат, наибольшего - в куб и нахождения среднего арифметического полученных значений. 2.
Ответы (1)
Дано натуральное четырехзначное число, верно ли, что все его цифры различны? Написать программу.
Ответы (1)
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч). Используя текстовые файлы input, output.
Ответы (1)